Contacts
This page focusses on the functionality and behaviour of contact data syncing between StayOnHire and Xero once connected. Ideal for both new and experienced users.
Overview
For the best experience, we recommend having your Xero integration set as below for your contacts sync behaviour and direction:
Xero Resource: Contacts "Toggled on"
Sync Direction: "StayOnHire sends & receives"
StayOnHire Edibility: "Can be edited"

Configuration & Setup
To ensure your integration is setup correctly, complete the following checklist:
Complete the Xero Getting Started guide
How it Works
A simple overview of how this will look in your business:
Xero and StayOnHire sync contacts based on your Configuration & Setup
Xero Contacts sync to also be your Billing Contact in StayOnhire
StayOnHire invoices are mapped to Xero automatically with relevant contact details for your billing team
Merging Duplicate Contacts
Causes
There are some scenarios where you may experience a duplicate or similar contact. The most common causes of these are:
Your team may have created a new contact for one that already exists. i.e. Consider a quick spelling mistakes made in haste when building a job in StayOnHire
You integrate Xero after your business has already been using StayOnHire for a while. i.e. You've been manually creating contacts in StayOnHire (that you always new also existed in your Xero account)
Solution
1. Select duplicate contact rows
Head to your Contact page and select two rows that are duplicates:

2. Merge selected
Click the action button dropdown and select the option 'Merge (2) selected'

You may receive a prompt telling you both exist as separate contacts in your Xero integration:

Select which contact will become your new primary contact. You will then be presented with a preview of which primary contact details will be kept after the merge:

You will then receive one final confirmation:

Once merged, your unwanted contact will now be merged. This will also be reflected in your Xero integration once the page is refreshed:

Testing your integration
Confirm StayOnHire Receives
1. Confirm import settings
Check your integration sync direction is set to 'StayOnHire receives' or StayOnHire sends & receives' at a minimum:

2. Create a new contact in Xero
Navigate to your Xero Contacts page and create a new contact. In the below example, a contact named "AAA Created in Xero" exists in Xero, but has not been received by StayOnHire:

2. Confirm Sync to your Contact page
Once created, go into your StayOnHire Contacts page and click the 'sync icon':

If successful, the newly created contact will appear in your StayOnHire account:

Confirm StayOnHire Sends
1. Confirm export settings
Check your integration sync direction is set to 'StayOnHire sends' or StayOnHire sends & receives' at a minimum:

2. Create a new contact
Navigate to your StayOnHire Contacts page and create a new contact:

In the below example, a contact named "AAA Created in StayOnHire" exists in StayOnHire, but has not been received by Xero:

3. Trigger a sync
From the top right-hand side you your StayOnHire Contacts, click the sync button

You will now see the contact 'Xero 'Contact' field change sync status in StayOnHire.
Upon a refresh of your Xero contacts page, your new contact will also appear here.

4. Open in Xero
Clicking the Xero 'Contact' cell in StayOnHire will also reveal a reference.
By clicking this reference link, it will open the Xero contact directly in your Xero account:

Troubleshooting
Common issues relating to contacts not syncing may include:
Contact information may be invalid to sync i.e. Contact Name is not unique or their primary billing email address is invalid

If you're unable to resolve a sync error, please contact us via or live chat support or through your StayOnHire representative directly.
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